Хотите, мы Вам перезвоним?
  • Киев: (044) 383-54-55
  • Днепр-вск: (056) 767-50-05
  • Харьков: (057) 764-02-54
  • Запорожье: (061) 707-78-07
Мобильные номера
 
Продукция
 
Производители
 
Новости
 
Статьи

Как настроить IPTV на MikroTik

26.08.2016
  1. Установка пакета multicast
  2. Настройка IGMP Proxy
  3. Настройка Firewall
  4. Настройка Wi-Fi

Установка пакета multicast

Чтобы настроить IPTV на роутерах MikroTik, сначала необходимо установить дополнительный пакет multicast. Для этого выполните следующее:

  1. Перейдите на оффициальный сайт MikroTik по ссылке http://www.mikrotik.com/download;
  2. Определите, к какой серии относится ваш роутер, и версию операционной системы RouterOS, установленную на роутере. Если на сайте нет нужной версии, вам потребуется обновить операционную систему роутера до необходимой версии. Как это сделать можно прочитать в инструкции Как обновить MikroTik RouterOS;
  3. Нажмите на ссылку напротив Extra Packages и необходимой версии RouterOS, чтобы скачать дополнительные пакеты;
    Настройка MikroTik Extra Packages
     
  4. Распакуйте скаченный архив с дополнительными пакетами;
  5. Откройте в Winbox меню Files;
    Меню Files
     
  6. Перетащите из распакованной папки файл multicast-x.xx-mipsbe.npk в Winbox окно File List.
    MikroTik - Скопировать пакет multicast
     
  7. Перезагрузите роутер через меню System - Reboot или через терминал командой system reboot.

После перезагрузки в меню System - Packages должен появиться модуль multicast.

Модуль multicast в MikroTik

 

Настройка IGMP Proxy

Выполним настройку IGMP Proxy на MikroTik.

Откройте меню Routing - IGMP Proxy и нажмите синий плюсик, чтобы указать на какой порт приходит IPTV.

MikroTik - Настройка IPTV multicast

 

В выпадающем списке Interface выберите WAN порт, к которому подключен кабель интернет провайдера и поставьте галочку Upstream.

В поле Alternative Subnets укажите подсеть стриммеров. Если вы не знаете данные подсети, то попробуйте указать: 10.0.0.0/8, 172.16.0.0/12 и 192.168.0.0/16.

Я настраивал IPTV для Maxnet, и у меня все заработало c Alternative Subnets 0.0.0.0/0. Но так лучше не делать. Используйте 0.0.0.0/0 только если не смогли найти необходимую подсеть.

После ввода параметров нажмите кнопку OK.

MikroTik - Настройка входящего WAN порта IPTV

 

Еще раз нажмите синий плюсик, чтобы указать на какие порты передавать IPTV.

Add

 

В выпадающем списке Interface выберите порт, на который нужно пробросить IPTV, и нажмите кнопку OK.  В Interface желательно указывать один конкретный порт, чтобы не было проблем с производительностью роутера.

MikroTik - Настройка исходящих портов IPTV

 

Нажмите кнопку Settings и поставьте галочку напротив Quick Liave. Это позволит быстро переключаться между каналами.

Включение Quick Liave в MikroTik

 

Настройка Firewall

Чтобы фаервол пропускал IPTV, необходимо добавить разрешающие правила. Откройте меню New Terminal.

Добавление правил фаервола для MikroTik IPTV

 

Выполните в терминале следующие команды:

/ip firewall filter add action=accept chain=input comment="Allow IGMP" disabled=no in-interface=ether1 protocol=igmp

/ip firewall filter add action=accept chain=input comment="IPTV UDP incoming" disabled=no dst-port=1234 in-interface=ether1 protocol=udp

/ip firewall filter add action=accept chain=forward comment="IPTV UDP forwarding" disabled=no dst-port=1234 protocol=udp

ether1 - это интерфейс, на который приходит IPTV от провайдера. Если ваше имя отличается, укажите необходимое.

 

После этого откройте меню IP - Firewall и перейдите на вкладку Filter Rules. Созданные правила перетяните кнопкой мыши вверх выше запрещающих.

Правила фаервола MikroTik для IPTV

 

Настройка Wi-Fi

Если вы транслируете IPTV по Wi-Fi, то необходимо выполнить следующие настройки.

  1. Откройте меню Wireless.
  2. Перейдите на вкладку Interfaces.
  3. Откройте двойным щелчком беспроводной интерфейс wlan1.
  4. Перейдите на вкладку Wireless.
  5. Нажмите кнопку Advanced Mode.

Mikrotik Advanced Mode

 

Найдите параметр WMM Support и выберите enabled. Он включит поддержку Wi-Fi multimedia. Если у вас много клиентов, то его лучше не включать, поскольку один клиент может мультикастом съесть весь канал.

В параметре Multicast Helper выберите full. Это позволит отправлять мультикаст пакеты по MAC адресам клиентам, подключенным к Wi-Fi.

После этого нажмите кнопку OK.

Настройка MikroTik WMM Support и Multicast Helper

 

На этом настройка IPTV на MikroTik окончена.

 

Печатная версия Поделитесь статьёй:
  • Обычная форма
  • ВКонтакте
  • Facebook

Отзывы о статье

  Оценка: 4, Голосов: 31, Комментариев: 100

Добавить отзыв
Ваше Имя: *
Ваш e-mail:  

Отзыв: *
Оценка:  
Введите символы: *
Обновить
 
Андрей 14.03.2017 12:47:12
Подскажите, если можно пошагово, как настроить RB2011UiAS-2HnD-IN в режиме TriplePlay чтобы он на несколько портов (к примеру 2-4 и 6-8) получал нетегированный траффик интернета, на порт 5 и 8 IPTV (VLAN-35), а на порт 10 VoIP (VLAN-37)
Первый порт используется как WAN порт с получением IP адреса от интернет провайлера.
anton 08.02.2017 15:03:36
Mikrotik hAp Lite, похоже не тянет IPTV от Триолан Харьков. Телевизор Самсунг, подключен шнурком к микроту. Картинка сыпется, звук рветься.
Всё настроил по статье, и с учётом камментов. Ничего не помогло.
Мимо Микротика все стабильно работает.
Подскажите куда копать? Где может быть проблема?
Дима 08.02.2017 15:11:54
вместо brigde пробовал указать порт, к которому подключен телевизор?
anton 08.02.2017 15:20:20
да, в этом случаее вообще перестаёт работать IPTV. Только с bridge.
antpon 09.02.2017 08:03:23
И ещё заметил, что стал полностью падать вайфай, утроим или вечером хочу подключится к вайфаю, а сети моей вообще нет. До настройки iptv такого не было, хотя это может связано и с обновление прошивки до последней.
Дима 09.02.2017 11:11:28
попробуй откатить прошивку
Alex 09.03.2017 11:21:06
Выбери другой канал WiFi.
Выбей из бриджа порт, куда подключен телик, и включи в IGMP-прокси вместо бриджа только теликовый порт.
Andy 13.03.2017 10:53:06
Ну если выкинуть из бриджа, тогда ведь телеку не будут доступны ресурсы сети (сетевые папки и тд), или не?
Alex 16.03.2017 23:11:51
Если правильно сконфигурить, то все останется. Просто адрес сделай выбитого интерфейса статический из той же подсети, что и бридж, но тогда следи, чтобы не пересекались диапазоны, раздаваемые DHCP, если он у тебя есть. Ну и на обоих интерфейсах (бридж и выбитый) надо будет включить режим Proxy-ARP.
Alex 09.03.2017 11:32:34
Да, и если настраивал правила фаервола по статье, то обязательно обрати внимание на то, бегут ли пакеты в этих правилах, когда работает телик. Счетчики в правилах, в которых забит порт 1234 - 17(UDP), должны постоянно расти. Если телик хоть как-то работает, а счетчики не растут, то у тебя телик зацепился не через UDP, а через http-udp прокси. Если в Харькове и такой список каналов. Смени список (адрес списка), но трианальцам надо заплатить за это дело.
Андрей 15.03.2017 10:56:15
Попробуйте просто отключить DHCP Client если у вас PPPoE соединение.
Max 19.12.2016 16:13:13
для Maxnet IPTV
Alternative Subnets 10.102.19.18/32
Шляпа усатая 10.12.2016 19:51:07
все это фигня ребята, даже если мультикаст работает он валит трафик на все порты нагружая проц, нормально будет работать когда 7 версия будет ито не факт
Дима 16.12.2016 12:32:59
настрой на конкретный порт, если нужно
Павел 04.08.2016 12:12:35
Прошу помощи. Делаю пункт 6, 7 - multicast пакет в packagelist не появляется. Железяка RB952Ui-5ac2nD 6.36
Сергей 12.09.2016 02:26:33
Не своё оборудование выбираете.
Alex 24.12.2015 15:33:36
Спасибо, отличная и простая статья. 5+
п.с Билайн-Москва работает с настройкой 0.0.0.0/0
Ростислав 09.05.2015 13:59:16
Привет!
Седлал все как написано... В закладке MFC пакеты побежали - но видео так и не работает.
ppoe поднимается на 1 порту
второй порт отдает на неуправляемый свитч к которому подключены телевизоры, компы и т.д.
остальные порты не используются вообще
В Routing - IGMP Proxy - создал два интерфейса:
1. На pppoe соединении входящий
2. на втором порту исходящий
правила в фаерволе всего два из данной статьи.
Плейлист вида:
#EXTINF: -1,16 Новий канал
rtp://225.1.1.129:1234
что делаю не так?
Alexsandr 13.02.2015 07:02:50
В поле Alternative Subnets укажите подсеть стриммеров. Если вы не знаете данные подсети, то попробуйте указать: 10.0.0.0/8, 172.16.0.0/12 и 192.168.0.0/16. Я настраивал IPTV для Maxnet, и у меня все заработало c Alternative Subnets 0.0.0.0/0.

таки лучше не насиловать железку и не указывать в стриммерах весь интернет)
Евгений 13.12.2014 07:52:44
Доброе утро. Есть в наличии две штуки SXT Lite5 настроенные бриджом. При запросе провайдерского IPTV по UDP картинка сыпется даже на SD каналах. Пакет Мультикаст поставил на обе антенны, но как его настраивать?
Страницы: 1, 2, 3, 4
Call-центр
  • +38 097 085-80-08
  • +38 099 238-88-98
  • +38 099 322-60-10
  • +38 063 563-33-93
  • График работы:
    Пн–Пт с 9 до 18
Магазины
  • Киев: +38 044 223-10-98
  • Харьков: +38 057 764-02-54
  • Днепр-ск: +38 056 767-50-05
  • Запорожье: +38 061 707-78-07
Наши партнеры
     
© 2003–2017 «Компания ТехноТрейд»
интернет-магазин сетевого оборудования
×
×
Валюта: