Хотите, мы Вам перезвоним?
  • Киев: (044) 383-54-55
  • Днепр-вск: (056) 767-50-05
  • Харьков: (057) 764-02-54
  • Запорожье: (061) 707-78-07
Мобильные номера
 
Продукция
 
Производители
 
Новости
 
Статьи

Bonding MikroTik — увеличиваем скорость Wi-Fi канала

18.02.2013
  1. Настройка Bonding
  2. Тестирование связи
  3. Мониторинг связи

В операционной системе MikroTik RouterOS есть функция Bonding, позволяющая увеличить пропускную способность Wi-Fi за счет объединения нескольких Wi-Fi каналов в один.

Допустим у вас стоит задача получить Wi-Fi канал с пропускной способностью 200 Мбит/с. Для этого необходимо установить два Wi-Fi моста со скоростью 100 Мбит/с каждый и объединить их в единый канал с помощью роутеров MikroTik или компьютеров x86 с установленной операционной системой RouterOS. Bonding довольно требователен к ресурсам, поэтому необходимо использовать мощные роутеры MikroTik или компьютеры.

При объединении Wi-Fi каналов необходимо чтобы их скорости были одинаковые, поскольку склеивание будет происходить по менее скоростному каналу. Например, если у вас один беспроводной канал имеет скорость 90 Мбит/с, а второй — 30 Мбит/с, то после объединения общая скорость получится 60 Мбит/с.

Настройка Bonding

Принцип работы Bonding заключается в следующем: создаются несколько виртуальных EoIP интерфейсов, после чего они объединяются в единый Wi-Fi канал.

Рассмотрим пример, как объединить два беспроводных моста, чтобы увеличить скорость Wi-Fi канала.

Настройка Bounding на MikroTik

У нас есть два роутера R1 и R2. Каждый роутер имеет два беспроводных интерфейса wlan0 и wlan1, которым назначены свои IP адреса.

Bounding может работать только на канальном уровне OSI Layer 2, поэтому нам необходимо создать EoIP интерфейсы на каждом беспроводном интерфейсе wlan0 и wlan1. Для этого выполните в терминале следующие команды:

  • на роутере R1:
  • [admin@MikroTik] > /interface eoip add remote-address=10.0.1.1/24 tunnel-id=1
    [admin@MikroTik] > /interface eoip add remote-address=10.0.2.1/24 tunnel-id=2
  • на роутере R2:
  • [admin@MikroTik] > /interface eoip add remote-address=10.1.1.1/24 tunnel-id=1
    [admin@MikroTik] > /interface eoip add remote-address=10.2.2.1/24 tunnel-id=2

 

Далее добавляем интерфейс bounding и делаем EoIP интерфейсы как slaves (ведомым)

  • на роутере R1:
  • [admin@MikroTik] > / interface bonding add slaves=eoip-tunnel1,eoip-tunnel2 mode=balance-rr
  • на роутере R2:
  • [admin@MikroTik] > / interface bonding add slaves=eoip-tunnel1,eoip-tunnel2 mode=balance-rr

 

В заключении назначаем IP адреса bounding интерфейсу:

  • на роутере R1:
  • [admin@MikroTik] > / ip address add address 192.168.0.1/24 interface=bonding1
  • на роутере R2:
  • [admin@MikroTik] > / ip address add address 192.168.0.2/24 interface=bonding1

Тестирование связи

Теперь оба маршрутизатора могут связаться друг с другом, используя IP адреса из подсети 192.168.0.0/24. Чтобы проверить работоспособность бондинга, выполните в терминале следующие команды:

  • на роутере R1:
  • [admin@MikroTik] > /interface monitor-traffic eoip-tunnel1,eoip-tunnel2
  • на роутере R2:
  • [admin@MikroTik] > /tool bandwidth-test 192.168.0.1 direction=transmit

 

В итоге вы увидите трафик, который равномерно распределяется между двумя EoIP интерфейсами:

[admin@MikroTik] > /int monitor-traffic eoip-tunnel1,eoip-tunnel2
     received-packets-per-second: 685    685
           received-bits-per-second: 8.0Mbps  8.0Mbps
           sent-packets-per-second: 21       20
                 sent-bits-per-second: 11.9kbps 11.0kbps
     received-packets-per-second: 898    899
           received-bits-per-second: 10.6Mbps 10.6Mbps
          sent-packets-per-second: 20       21
                sent-bits-per-second: 11.0kbps 11.9kbps
    received-packets-per-second: 975    975
          received-bits-per-second: 11.5Mbps 11.5Mbps
          sent-packets-per-second: 22       22
                sent-bits-per-second: 12.4kbps 12.3kbps
    received-packets-per-second: 980    980
          received-bits-per-second: 11.6Mbps 11.6Mbps
          sent-packets-per-second: 21      21
                sent-bits-per-second: 11.9kbps 11.8kbps
    received-packets-per-second: 977    977
          received-bits-per-second: 11.6Mbps 11.5Mbps
           sent-packets-per-second: 21       21
                 sent-bits-per-second: 11.9kbps 11.8kbps
-- [Q quit|D dump|C-z pause]
[admin@MikroTik] >
 

Мониторинг связи

Если использовать выше описанную конфигурацию, то при отказе работы одного из Wi-Fi каналов, происходит падение пропускной способности на интерфейсе bonding. Чтобы отследить проблемы со связью, необходимо выполнять мониторинг соединений. Это делается в большинстве конфигураций bounding. Для включения ARP мониторинга выполните в терминале следующие команды:

  • на роутере R1:
  • [admin@MikroTik] > / interface bonding set bonding1 link-monitoring=arp arp-ip-targets=192.168.0.2
  • на роутере R2:
  • [admin@MikroTik] > / interface bonding set bonding1 link-monitoring=arp arp-ip-targets=192.168.0.1
Печатная версия Поделитесь статьёй:
  • Обычная форма
  • ВКонтакте
  • Facebook

Отзывы о статье

  Оценка: 0, Голосов: 0, Комментариев: 0

Добавить отзыв
Ваше Имя: *
Ваш e-mail:  

Отзыв: *
Оценка:  
Введите символы: *
Обновить
 
Call-центр
  • +38 097 085-80-08
  • +38 099 238-88-98
  • +38 099 322-60-10
  • +38 063 563-33-93
  • График работы:
    Пн–Пт с 9 до 18
Магазины
  • Киев: +38 044 223-10-98
  • Харьков: +38 057 764-02-54
  • Днепр-ск: +38 056 767-50-05
  • Запорожье: +38 061 707-78-07
Наши партнеры
     
© 2003–2016 «Компания ТехноТрейд»
интернет-магазин сетевого оборудования
×
×
Валюта: