Продукция
 
Производители
 
Новости
 
Статьи

Как сохранить, восстановить и перенести настройки MikroTik

03.04.2017
  1. Сохранение и восстановление настроек MikroTik
  2. Перенос настроек MikroTik на другое устройство
  3. Частичный перенос настроек
  4. Автоматическое создание резервных настроек MikroTik и отправка на email

 

Операционная система RouterOS позволяет сохранить настройки MikroTik, и быстро восстановить резервную копию, чтобы возобновить работу устройства. Это очень удобно, если вы напортачили с настройками, или вам нужно выполнить одинаковую настройку нескольких устройств MikroTik. В этой статье мы расскажем, как создать резервную копию настроек MikroTik, восстановить ее или перенести на другое устройство.

Сохранение и восстановление настроек MikroTik

Чтобы сохранить настройки MikroTik, выполните следующее:

  1. Откройте в программе Winbox меню Files.
  2. Нажмите кнопку Backup.
  3. Во всплывающем окне нажмите кнопку Backup.
    При желании можете указать в поле Name имя файла и пароль в поле Password.
    По умолчанию файлы бэкапов шифруются, чтобы злоумышленники не смогли извлечь из них пароли, например, к Wi-Fi. Галочка Don't encrypt позволяет отключить шифрование файла с резервными настройками.

Сохранить настройки MikroTik

 

После этого в списке появится файл с именем MikroTik-xxxxxxxx-xxxx.backup , где ххххххxx-хххх - это дата и время создания файла.

Файл с бэкапом настроек MikroTik

Внимание! Файл MikroTik-xxxxxxxx-xxxx.backup предназначен для восстановления настроек только на устройстве, на котором он создан. Его нельзя использовать для переноса настроек на другое устройство. Иначе у вас перенесутся MAC-адреса интерфейсов, в сети будут два одинаковых устройства и возникнет конфликт.
Для переноса настроек используются специальные файлы в текстовом формате, описанные ниже в разделе Перенос настроек MikroTik на другое устройство.

 

Далее резервную копию конфигурации MikroTik можно сохранить на компьютер, перетащив файл на рабочий стол или в проводник Windows.

Сохранить настройки MikroTik на компьютер

 

Перед восстановлением настроек, нужно сбросить все настройки устройства, чтобы в нем не остались какие-то настройки из текущей конфигурации.

  1. Откройте меню System - Reset Configuration.
  2. Поставьте галочку No Default Configuration.
  3. Нажмите кнопку Reset Configuration.
  4. В всплывающем окне нажмите Yes для сброса настроек и перезагрузки устройства.

Сброс настроек MikroTik

 

После перезагрузки подключайтесь к устройству по MAC адресу, поскольку IP адрес будет отсутствовать. В программе Winbox нужно нажать мышкой на MAC-адрес устройства и нажать кнопку Connect.

 

Чтобы восстановить конфигурацию MikroTik, выполните следующее:

  1. Откройте меню Files.
  2. Выберите файл с резервной копией.
  3. Нажмите кнопку Restore.
  4. В появившемся окне нажмите кнопку Restore.
    Если вы делали бэкап с паролем, то введите пароль в поле Password.
  5. В всплывающем окне нажмите Yes для восстановления конфигурации и перезагрузки устройства.

Восстановить настройки MikroTik

 

Перенос настроек MikroTik на другое устройство

Для переноса настроек на другое устройство MikroTik, нужно сохранить настройки в файл в текстовом виде. Этот файл можно будет редактировать, если возникнут проблемы при переносе настроек.

Переносить настройки можно только на устройства MikroTik со схожей аппаратной конфигурацией. Вы не сможете перенести настройки с роутера на 10 LAN портов, на роутер с 5-ю LAN портами. При этом будут выдаваться ошибки. Можно конечно вручную отредактировать файл с настройками, но это довольно сложный и долгий процесс.

Чтобы сохранить настройки MikroTik в текстовом формате, откройте меню New Terminal и выполните следующую команду:

export file=config_backup_20170403.rsc

Название файла может быть любым. В названии файла желательно указывать дату, чтобы потом не запутаться. В данном случае в названии файла указана дата 20170403 - 3 апреля 2017 года. Файлы с датой, указанной таким образом, будет очень удобно сортировать по имени в проводнике или в файловом менеджере Total Commander, FAR Manager или MC (Linux).

 

Далее нужно скопировать созданный файл в другое устройство. Для этого сначала перетащите файл на рабочий стол Windows. После этого перетащите его в новое устройство в меню Files.

 

Перед импортированием настроек, нужно сбросить конфигурацию устройства, иначе будет конфликт с текущими настройками и при импорте будут выдаваться ошибки.

  1. Откройте меню System - Reset Configuration.
  2. Поставьте галочку No Default Configuration.
  3. Нажмите кнопку Reset Configuration.
  4. В всплывающем окне нажмите Yes для сброса настроек и перезагрузки устройства.

Сброс настроек MikroTik

 

 

Чтобы импортировать настройки MikroTik, откройте меню New Terminal и выполните следующую команду:

import file=config_backup_20170403.rsc

 

При переносе настроек между похожими роутерами MikroTik с одинаковым количеством портов, но с разными процессорами или памятью, во время импорта могут возникать ошибки. Я как-то пытался перенести настройки между двумя очень схожими роутерами. При этом выдавало ошибку, что указанная частота памяти не поддерживается устройством. В этом случае откройте файл с настройками на компьютере, отредактируйте необходимую настройку или удалите ее.

 

Частичный перенос настроек

Бывают ситуации, когда нужно сохранить часть настроек, например, правила фаервола, скрипты, NAT, правила маркировки пакетов и т.п. Для этого помогут следующие команды:

ip address export file=ip.rsc
ip firewall mangle export file=mangle.rsc
ip firewall nat export file=nat.rsc
ip firewall filter export file=filter.rsc
queue simple export file=simple.rsc
ip dns export file=dns.rsc
system script export file=script.rsc
system scheduler export file=scheduler.rsc
tool e-mail export file=email.rsc
ip firewall address-list export file=address-list.rsc
ip route export file=route.rsc
ip dhcp-server network export file=network.rsc
queue type export file=type.rsc
queue tree export file=tree.rsc
queue simple export file=simple.rsc
interface ethernet export file=ethernet.rsc
ip pool export file=pool.rsc
ppp profile export file=profile.rsc
system logging export file=log.rsc

 

Автоматическое создание резервных настроек MikroTik и отправка на email

Чтобы не забывать делать резервные копии конфигурации MikroTik, вы можете автоматизировать этот процесс и отправлять бэкапы себе на email.

 

Создание скрипта

Откройте меню System - Scripts и нажмите "красный плюсик", чтобы добавить новый скрипт. В поле Name укажите название скрипта, в поле Source вставьте скрипт и нажмите кнопку OK.

Не забудьте в скрипте изменить значения [email protected] и your_gmail_password на свои.

Скрипт создания резервной копии настроек MikroTik и отправки на email

 

Чтобы протестировать работу скрипта, нажмите кнопку Run Script, и на ваш почтовый ящик будут высланы резервные копии. Процесс выполнения скрипта можно отслеживать в меню Log.

 

Скрипт для отправки резервной копии настроек MikroTik на email:

Для RouterOS v6.x

{
:log info "Starting Backup Script...";
:local sysname [/system identity get name];
:local sysver [/system package get system version];
:log info "Flushing DNS cache...";
/ip dns cache flush;
:delay 2;
:log info "Deleting last Backups...";
:foreach i in=[/file find] do={:if ([:typeof [:find [/file get $i name] \
"$sysname-backup-"]]!="nil") do={/file remove $i}};
:delay 2;
:local smtpserv [:resolve "smtp.gmail.com"];
:local Eaccount "[email protected]";
:local pass "your_gmail_password";
:local backupfile ("$sysname-backup-" . \
[:pick [/system clock get date] 7 11] . [:pick [/system \
clock get date] 0 3] . [:pick [/system clock get date] 4 6] . ".backup");
:log info "Creating new Full Backup file...";
/system backup save name=$backupfile;
:delay 2;
:log info "Sending Full Backup file via E-mail...";
/tool e-mail send from="<$Eaccount>" to=$Eaccount server=$smtpserv \
port=587 user=$Eaccount password=$pass start-tls=yes file=$backupfile \
subject=("$sysname Full Backup (" . [/system clock get date] . ")") \
body=("$sysname full Backup file see in attachment.\nRouterOS version: \
$sysver\nTime and Date stamp: " . [/system clock get time] . " " . \
[/system clock get date]);
:delay 5;
:local exportfile ("$sysname-backup-" . \
[:pick [/system clock get date] 7 11] . [:pick [/system \
clock get date] 0 3] . [:pick [/system clock get date] 4 6] . ".rsc");
:log info "Creating new Setup Script file...";
/export verbose file=$exportfile;
:delay 2;
:log info "Sending Setup Script file via E-mail...";
/tool e-mail send from="<$Eaccount>" to=$Eaccount server=$smtpserv \
port=587 user=$Eaccount password=$pass start-tls=yes file=$exportfile \
subject=("$sysname Setup Script Backup (" . [/system clock get date] . \
")") body=("$sysname Setup Script file see in attachment.\nRouterOS \
version: $sysver\nTime and Date stamp: " . [/system clock get time] . " \
" . [/system clock get date]);
:delay 5;
:log info "All System Backups emailed successfully.\nBackuping completed.";
}

 

В примере указан скрипт для сервиса Gmail. При отправке через Gmail нужно предварительно разрешить ненадежным приложениям доступ к аккаунту. Для этого залогиньтесь, на странице "Мой аккаунт" перейдите в раздел "Ненадежные приложения" и выберите "Включить". Подробнее читайте Как разрешить ненадежным приложениям доступ к аккаунту.

Разрешить доступ ненадежных приложения к Gmail

 

Чтобы использовать сервис Рамблер Почта, замените в скрипте smtp.gmail.com на mail.rambler.ru. Чтобы использовать сервис Яндекс Почта, замените в скрипте smtp.gmail.com на smtp.yandex.ru. Также не забудьте изменить значения [email protected] и your_gmail_password на свои.

 

Настройка планировщика

Теперь нужно настроить с какой периодичностью будут создаваться резервные копии, и отправляться на email. Для этого настроим планировщик (Sheduler).

Откройте меню System - Sheduler и нажмите кнопку "плюсик", чтобы добавить новую задачу.

MikroTik: Добавить задание в планировщик

 

В открывшемся окне настраиваем параметры задачи:

  • в поле Name указываем имя задачи, например send_backup_to_email;
  • в поле Interval указываем с какой периодичностью будет выполняться скрипт. Мы указали интервал 24 часа. Для отладки работы планировщика укажите интервал 5 минут и текущее время Start Time. И не забудьте настроить время на MikroTik в меню System - Clock;
  • в поле On Event указываем, какую команду необходимо выполнить при запуске задачи. Мы указали команду /system script run backup_to_email, которая запускает скрипт backup_to_email;
  • нажимаем кнопку OK для сохранения задачи.

MikroTik: Настройка параметров задачи планировщика

 

Теперь каждый день в 00:00:00 будет создаваться резервная конфигурация MikroTik и отправляться вам на email.

 

Печатная версия Поделитесь статьёй:
  • Обычная форма
  • Facebook

Отзывы о статье

  Оценка: 5, Голосов: 24, Комментариев: 68

Добавить отзыв
Ваше Имя: *
Ваш e-mail:  

Отзыв: *
Оценка:  
Введите символы: *
Обновить
 
Андрей 03.08.2021 09:40:30
При запуске скрипта ошибка "Error sending e-mail : invalid BODY"
xan 12.04.2021 07:23:39
Не работает на версии 7
Что надо подправить?
Андрей 27.01.2021 10:38:52
Не могу подключится через winbox к своему RB750.
Если логиниться с Win7 через winbox на мак адрес - подключаюсь без проблем, пробую грузится на єтом же компе с Win10 подключаюсь через винбокс - ошибка - переключитесь в Legacy mode. Иду в tools включаю legacy mode - ошибки нет, но зайти всеравно не могу. логин виснет с надписью "logining..."
I.CaR Soft 04.12.2020 05:25:29
Спасибо огромное за полезные материалы!
gekagal 23.11.2019 20:38:11
Подскажите пожалуйста что может быть, часто стала пропадать сеть вай фай, пропала, через время появилась. Что может быть?
Техподдержка 25.11.2019 11:41:19
Возможно, аппаратная проблема.
Maxim Davidyuk 05.11.2019 12:36:22
Спасибо. Как раз столкнулся с вопросом переноса настроек на другой тип роутера.
alex 21.08.2019 20:53:53
Понятно, что бекап нельзя накатывать на устройство, которое чем-то отличается. Но для такого сценария -- роутер вышел из строя, имееется другой, точно такой же, необходимо очень быстро сделать из него клон прежнего, пусть всё, включая МАКи будет тем же -- бекап годится? Если нет, то какой от него толк? Только не случай, если кто-то по ошибке сбросит конфиг?
Техподдержка 22.08.2019 10:06:29
Если имеется другой точно такой же роутер, то бекап годится.
Главное, чтобы они не пересекались с одинаковыми MAC в одной подсети.
міша 09.06.2019 16:41:58
микротик чомусь нетримає файли бекапу в розілі files
піся перагрузки виаляє даже немає файлика ресет стандарних кастройки
Техподдержка 10.06.2019 13:27:12
Восстановите прошивку через Netinstall и обязательно измените пароль администратора.
Не используйте резервные копии настроек, настройте роутер заново.
Roman 28.11.2018 00:39:45
Здравствуйте !
v6.43.4
У меня стоит двухфакторная авторизация на почте гугл я сделел так : создал пароль приложения в акк гугла

:local smtpserv [:resolve "173.194.69.108"];

:local Eaccount [email protected];

:local pas пароль приложения;

Почему то со строчкой

:local smtpserv [:resolve "smtp.gmail.com"];

почту не отправляет.
Страницы: 1, 2, 3, 4
Магазин
Техподдержка
Наши партнеры
   
© 2003–2021 «Компания ТехноТрейд»
интернет-магазин сетевого оборудования
×
×
Валюта: