Продукция
 
Производители
 
Новости
 
Статьи

Как настроить IPTV на MikroTik

26.08.2016
  1. Установка пакета multicast
  2. Настройка IGMP Proxy
  3. Настройка Firewall
  4. Настройка Wi-Fi

Установка пакета multicast

Чтобы настроить IPTV на роутерах MikroTik, сначала необходимо установить дополнительный пакет multicast. Для этого выполните следующее:

  1. Перейдите на оффициальный сайт MikroTik по ссылке http://www.mikrotik.com/download;
  2. Определите, к какой серии относится ваш роутер, и версию операционной системы RouterOS, установленную на роутере. Если на сайте нет нужной версии, вам потребуется обновить операционную систему роутера до необходимой версии. Как это сделать можно прочитать в инструкции Как обновить MikroTik RouterOS;
  3. Нажмите на ссылку напротив Extra Packages и необходимой версии RouterOS, чтобы скачать дополнительные пакеты;
    Настройка MikroTik Extra Packages
     
  4. Распакуйте скаченный архив с дополнительными пакетами;
  5. Откройте в Winbox меню Files;
    Меню Files
     
  6. Перетащите из распакованной папки файл multicast-x.xx-mipsbe.npk в Winbox окно File List.
    MikroTik - Скопировать пакет multicast
     
  7. Перезагрузите роутер через меню System - Reboot или через терминал командой system reboot.

После перезагрузки в меню System - Packages должен появиться модуль multicast.

Модуль multicast в MikroTik

 

Настройка IGMP Proxy

Выполним настройку IGMP Proxy на MikroTik.

Откройте меню Routing - IGMP Proxy и нажмите синий плюсик, чтобы указать на какой порт приходит IPTV.

MikroTik - Настройка IPTV multicast

 

В выпадающем списке Interface выберите WAN порт, к которому подключен кабель интернет провайдера и поставьте галочку Upstream.

В поле Alternative Subnets укажите подсеть стриммеров. Если вы не знаете данные подсети, то попробуйте указать: 10.0.0.0/8, 172.16.0.0/12 и 192.168.0.0/16.

Я настраивал IPTV для Maxnet, и у меня все заработало c Alternative Subnets 0.0.0.0/0. Но так лучше не делать. Используйте 0.0.0.0/0 только если не смогли найти необходимую подсеть.

После ввода параметров нажмите кнопку OK.

MikroTik - Настройка входящего WAN порта IPTV

 

Еще раз нажмите синий плюсик, чтобы указать на какие порты передавать IPTV.

Add

 

В выпадающем списке Interface выберите порт, на который нужно пробросить IPTV, и нажмите кнопку OK.  В Interface желательно указывать один конкретный порт, чтобы не было проблем с производительностью роутера.

MikroTik - Настройка исходящих портов IPTV

 

Нажмите кнопку Settings и поставьте галочку напротив Quick Liave. Это позволит быстро переключаться между каналами.

Включение Quick Liave в MikroTik

 

Настройка Firewall

Чтобы фаервол пропускал IPTV, необходимо добавить разрешающие правила. Откройте меню New Terminal.

Добавление правил фаервола для MikroTik IPTV

 

Выполните в терминале следующие команды:

/ip firewall filter add action=accept chain=input comment="Allow IGMP" disabled=no in-interface=ether1 protocol=igmp

/ip firewall filter add action=accept chain=forward comment="IPTV UDP forwarding" disabled=no dst-port=1234 protocol=udp

ether1 - это интерфейс, на который приходит IPTV от провайдера. Если ваше имя отличается, укажите необходимое.

 

После этого откройте меню IP - Firewall и перейдите на вкладку Filter Rules. Созданные правила перетяните кнопкой мыши вверх выше запрещающих.

Правила фаервола MikroTik для IPTV

 

Настройка Wi-Fi

Если вы транслируете IPTV по Wi-Fi, то необходимо выполнить следующие настройки.

  1. Откройте меню Wireless.
  2. Перейдите на вкладку Interfaces.
  3. Откройте двойным щелчком беспроводной интерфейс wlan1.
  4. Перейдите на вкладку Wireless.
  5. Нажмите кнопку Advanced Mode.

Mikrotik Advanced Mode

 

Найдите параметр WMM Support и выберите enabled. Он включит поддержку Wi-Fi multimedia. Если у вас много клиентов, то его лучше не включать, поскольку один клиент может мультикастом съесть весь канал.

В параметре Multicast Helper выберите full. Это позволит отправлять мультикаст пакеты по MAC адресам клиентам, подключенным к Wi-Fi.

После этого нажмите кнопку OK.

Настройка MikroTik WMM Support и Multicast Helper

 

На этом настройка IPTV на MikroTik окончена.

 

Печатная версия Поделитесь статьёй:
  • Обычная форма
  • Facebook

Отзывы о статье

  Оценка: 4, Голосов: 36, Комментариев: 118
Serg0FFan 06.05.2013 21:16:47
Спасибо за статью, но у меня не сработало, провайдер билайн.
Сделал так:
1) 5 порт ethernet настроил так что он сам по себе (в интерфейсах выбираем ether5-slave-local и значение Master port ставим в none
2) в бриджах создаём новый бридж, там же в закладке порты добавляем два порта, первый ether1-gateway, второй ether5-slave-local. В обоих ессно бриджем выставлен новый бридж
3) втыкаем кабель от тв приставки в 5 порт и радуемся жизни :)
Serg0FFan 05.06.2013 23:18:04
Описанный способ можно применять только при условии что к 5ому порту у вас подключена ТВ приставка, если вы хотите на компе смотреть IPTV то тут все по другому.
Serg0FFan 05.06.2013 23:43:26
Да, еще, если вы "счастливый" клиент билайна то вы живете на яркой стороне :) У них все не просто, у них IPTV трафик идёт на локальный интерфейс (тот что напрямую подключается по ethernet) а интернет трафик идёт через l2tp, потому надо на локальном фейсе в фильтре разрешить прохождение трафика с сетей 233.33.210.0/24 и 233.33.220.0/24 чтобы все взлетело, иначе никак :)
Анатолий 25.07.2013 13:26:38
А пример правила в фильтр прохождение трафика с сетей 233.33.210.0/24 и 233.33.220.0/24 можно?
Дима 25.03.2013 15:11:06
Настроил IP-TV как описано выше, все получилось! Но изображение постоянно сыпит и прерывается звук. Интернет 100мбит, канал свободный, без микротика все работает идеально!
В чем может быть проблема?
Андрей 25.03.2013 18:08:15
попробуй в Interface указать конкретный интерфейс, а не Bridge
Дима 26.03.2013 10:12:59
Попробывал! Под IP-TV выделил отдельный интерфейс, но проблема осталась(
Андрей 26.03.2013 11:23:34
подключаешься по кабелю или по Wi-Fi? если по Wi-Fi, то в каком стандарте подключается адаптер и на какой скорости?
Дима 26.03.2013 12:49:55
Подключал по кабелю напрямую в комп, да и по Wi-Fi тоже самое! IP-TV стабильно тянет 4-6 мегабит в зависимости от канала, но картинка сыпиться и звук заикается
Гендос 14.03.2013 13:59:38
В поле Alternative Subnets 0.0.0.0/0. помогло
Валентин 08.03.2013 14:36:26
настроить igmp - половина работы. надо еще файрволл подкрутить. я пока пять правил не добавил, так нифига и не заработало. спасибо, что добрые люди подсказали.
Иван 15.12.2012 08:12:10
Всё работает. До первой перезагрузки роутера. После перезагрузки напротив правил в IGMP появился префикс I (Inactive). Заново создаю - не помогает.
Иван 15.12.2012 09:35:45
Какой бы интерфейс не указывал в downstream, всё равно идёт на бридж трансляция. Как сделать так, чтобы IPTV транслировалось только на тот интерфейс, на котором запускается IPTV?
Дима 17.12.2012 10:41:59
возможно у тебя несколько портов настроены в свитч (bridge). удали интерфейс bridge и укажи конкретный порт, на который пробрасывать iptv.
Сергей 14.11.2012 01:48:19
Статья супер.
Спасибо.
У меня тоже все заработало c Alternative Subnets 0.0.0.0/0 Триолан Полтава.
Dj 10.11.2012 18:34:08
/routing igmp-proxy
set query-interval=1m query-response-interval=10s quick-leave=yes
/routing igmp-proxy interface
add alternative-subnets=10.0.0.0/8 disabled=no interface=triolan threshold=1 upstream=yes
add alternative-subnets="" disabled=no interface=all threshold=1 upstream=no

Для триолана работает такое
Сережа 08.11.2012 23:28:50
не сработало
Дима 09.11.2012 09:28:26
может фаервол не пускает. попробуй его отключить.
для triolan попробуй добавить Alternative Subnets 10.5.200.0/24, 224.0.0.0/24 и 239.0.0.0/24
Страницы: 1, 2, 3, 4, 5

Добавить отзыв
Ваше Имя: *
Ваш e-mail:  

Отзыв: *
Оценка:  
Введите символы: *
Обновить
 
Call-центр
  • +38 097 085-80-08
  • +38 099 238-88-98
  • +38 099 322-60-10
  • +38 063 563-33-93
  • График работы:
    Пн–Пт с 9 до 18
Магазины
  • Киев: +38 044 223-10-98
  • Харьков: +38 057 764-02-54
  • Днепр-ск: +38 056 767-50-05
  • Запорожье: +38 061 707-78-07
Наши партнеры
     
© 2003–2020 «Компания ТехноТрейд»
интернет-магазин сетевого оборудования
×
×
Валюта: