Хотите, мы Вам перезвоним?
  • Киев: (044) 223-10-98
  • Днепр-вск: (056) 767-50-05
  • Харьков: (057) 764-02-54
  • Запорожье: (061) 707-78-07
Мобильные номера
 
Продукция
 
Производители
 
Новости
 
Статьи

Настройка HotSpot на MikroTik с маркетинговыми возможностями

13.02.2019

Если смотреть на реалии сегодняшнего дня, то почти у каждого посетителя имеется мобильный гаджет, который подключаются к бесплатной публичной сети WiFi вашего заведения. Рассмотрим как можно “прокачать” публичную сеть WiFi чтобы кроме предоставления интернета, она умела приносить еще и пользу для развития вашего бизнеса. Для решения данной задачи на помощь к нам придет устройство MikroTik c его базовым функционалом из коробки hotspot. Используя данный функционал вы можете не просто предоставлять интернет пользователю, а еще и показывать страницу-приветствия с информацией о вашем бренде. Так же это является отличным способом оповестить клиента об акциях и скидках.

Но каждая рекламная кампания или акция не вечна, а с её окончанием приходит новая, которая требует очередных изменений в вашей рекламной странице-приветствия, с последующим залитием файлов на устройство. Выполнять эти действия каждый раз вручную, согласимся, не самая перспективная затея. А если таких устройств несколько и они разнесены территориально....?

Рассмотрим как можно автоматизировать управление hotspot`ом используя сервис WiFi Point. Данный сервис позволит вам сэкономить большое количество времени по настройке и дальнейшем обслуживанием устройств. Вдобавок вы получите дополнительный функционал который превратит Ваш обычный роутер в мощный маркетинговый инструмент.

WiFi авторизация с  показом рекламы

 

Приступим настройке маршрутизатора. Рассмотрим в качестве примера настройку модели MikroTik hAP lite RB941-2nD. Справедливости ради, можно сказать, что для данной задачи подойдет любой беспроводной маршрутизатор фирмы MikroTik, все зависит от того где планируется использовать устройство. Данная модель хорошо себя зарекомендовала как бюджетный, надежный WiFi роутер, который подойдет для небольшого кафе или любого другого заведения.

 

1. Подключение

Подключим кабель интернет-провайдера в первый порт маршрутизатора, а во второй сетевой кабель соединенный собственно с нашим компьютером на котором и будем производить дальнейшую настройку.

Маршрутизаторы фирмы MikroTik имеют в арсенале несколько способов настройки. Мы будем использовать вариант с использованием штатной программы Winbox.

Собственно запустив программу Winbox на вкладке Neighbors мы увидим свой роутер. Выбираем, нажав мышкой на мак адрес устройства, введем логин admin (по умолчанию), пароль оставляем пустой. После этого нажимаем на кнопку Connect

WiFi Point. Mikrotik Neighbors

 

При первом подключении к роутеру появится следующее окно:

WiFi Point. Mikrotik конфигурация по умолчанию

 

В данной статье рассмотрим работу со стандартными параметрами, поэтому нажмем кнопку OK, в противном случае базовую настройку маршрутизатора необходимо будет произвести самостоятельно. В базовой настройке уже настроен DHCP клиент, проверим что он получил IP адрес и все работает. Для этого перейдем в меню IP - DHCP Client

WiFi Point. Mikrotik настройка DHCP

 

Видим что DHCP клиент получил все необходимое. На этом шаге на роутере уже должен появится интернет, проверим это открыв меню Tools - Ping. В поле Ping To указываем 8.8.8.8 и нажимаем кнопку Start. Если у вас результат как на картинке ниже, то это означает что доступ к сети интернет получен и можно продвигаться далее

WiFi Point. Проверка доступности интернета

 

 

2. Обновление прошивки

Обновим роутер до последней стабильной прошивки. Для этого перейдем в меню System - Packages

WiFi Point. Установленные пакеты Mikrotik

 

Нажмем кнопку Check for Updates. В окне выбираем Stable и нажимаем кнопку Download&Install. Роутер скачает прошивку и будет автоматически перезагружен. После этого снова необходимо будет подключиться к нему через WinBox

WiFi Point. Обновление пакетов Mikrotik

 

 

3. Настройка аккаунта администратора

Изменим стандартный пароль администратора. Откроем меню System - Users.

WiFi Point. Измение пароля по умолчанию для пользотеля admin

 

Выберем свойства пользователя admin и нажимаем Password для создания нового пароля

WiFi авторизация. Смена пароля

 

 

4. Настройка гостевого интерфейса Wi-Fi

Создадим для хостпота отдельный интерфейс Bridge. Для этого переходим в меню Bridge нажимаем + .

WiFi с рекламой. Настройка bridge

 

В появившемся окне в поле Name указываем название интерфейса wifi-bridge. На этом создание моста заверено.

Добавим в только что созданный мост WiFi интерфейс, для этого перейдем во вкладку Ports

WiFi по СМС. Добавление порта в bridge

 

Исходя из того что видим на картинке, WiFi интерфейс добавлен в мост из стандартной конфигурации. Изменим значение поля Bridge на новый выбрав wifi-bridge

WiFi для кафе. Добавление wifi интерфейса в bridge

 

 

5. Настройка WiFi интерфейса

Откроем меню Wireless. Для изменения дважды кликнем на wlan1. Во вкладке Wireless укажем режим параметры Mode, Band, Channel width, SSID. В параметре SSID указываем желаемое название сети которое будут видеть гости.

WiFi для заведения. Настройка WiFi на Mikrotik

 

Теперь наша беспроводная сеть доступна к подключению.

 

6. Создание и настройка Hotspot

Перейдем в меню IP - Hotspot и нажмем кнопку Hotspot Setup, которая запустит мастер настройки.

WiFi Hotspot. Мастер настройки hotspota

 

На первом шаге указываем наш bridge-интерфейс wifi-bridge который создали ранее.

Выбор интерфейса для hotspota

 

На втором шаге мастера настроек, указываем подсеть для hotspot - 10.10.10.1/24. Включаем галочку Masquerade Network

Настройка подсети для hotspot

 

На третьем шаге укажем выдаваемый диапазон адресов для гостей

Настройка диапазона адресов Mikrotik hotspot

 

На четвертом шаге оставляем без изменений

Выбор сертификата для hotspot

 

Настройки на пятом шаге также оставим по умолчанию

Настройка SMTP для hotspot

 

На шестом шаге настроек DNS сервера указываем адрес 10.10.10.1

Настройка DNS для hotspota Mikrotik

 

На седьмом шаге настроек укажем DNS имя нашего сервиса a.wi-fi-point.com

DNS имя для hotspot

 

Восьмой шаг оставляем без изменений

Настройка пользователя для admin доступа

 

 

7. Изменение настроек Hotspot

Первое что необходимо выполнить - это изменить имя hotspot сервера. Для этого откроем меню System - RouterBoard и скопируем поле serial number которое и будет являться новым именем (поле Name в настройках хотспота). Также ограничим количество адресов на устройство сделал равным 1.

Настройка Serial ID для площадки WiFi

 

На следующем шаге изменим профиль пользователя. Перейдя во вкладку User Profiles - default установим параметр keep-alive timeout равный 5 минутам.

Настройка параметров User Profile

 

Теперь изменим профиль сервера, перейдя на вкладку Server Profiles.

Настройка параметров Server Profile

 

Откроем профиль hsprof1. На вкладке Login установим галочки MAC, HTTP PAP как на рисунке

Настройка параметров профиля hotspot

 

Переходим на следующую вкладку Radius.Выставляем галочки Use RADIUS, Accounting. Значение Interim Update выставляем 00:01:00.

Mikrotik Hotspot параметры RADIUS

 

 

8. Настройка Walled Garden IP List

Создадим четыре правила в Walled Garden IP List

DNS Host: c.wi-fi-point.com
DNS Host: a.wi-fi-point.com
DNS Host: wi-fi-point.com
DNS Host: api.wi-fi-point.com

Чтоб не создавать эти правила в ручную, откроем меню NewTerminal и вставим следующий код:

/ip hotspot walled-garden ip add dst-host=c.wi-fi-point.com

/ip hotspot walled-garden ip add dst-host=a.wi-fi-point.com

/ip hotspot walled-garden ip add dst-host=wi-fi-point.com

/ip hotspot walled-garden ip add dst-host=api.wi-fi-point.com

Результатом выполненного кода будут созданные правила

Mikrotik правила walled garden для работы Hotspot

 

 

9. Изменение страницы авторизации

Для замены родной страницы hotspot на страницу для работы с сервисом WiFi Point выполним следующие действия: перейдем в меню System - Scripts и нажмем на +.

В поле Name введем ReplaceLogin. В поле Source вставим код:

/tool fetch url="http://c.wi-fi-point.com/firmware/routeros/login" dst-path="login"; /import file-name=login; /

Нажмем кнопку Apply, а затем Run Script.

Mikrotik замена страницы-приветствия

 

 

10. Ограничения скорости

Сервис позволяет ограничивать скорость для посетителей, данные параметры можно изменять в Личном кабинета ( меню Площадки). Но вначале необходимо изменить стандартные настройки типов шейперов в меню Queues вкладка Queues Types

Изменим в типах default и default-small поле kind на значение sfq.

Настройка Queues Types

 

Для корректной нарезки скоростей шейпером отключим Fast Path. Перейдем в настройки Bridge:

Mikrotik отключение Fats Path bridge

 

Так же отключим Fast Path еще в меню IP - IP Settings

Mikrotik отключение Fats Path в IP setting

 

 

11. RADIUS

Авторизации посетителей на сервисе происходит по RADIUS протоколу. Настроим взаимодействие роутера и сервиса, добавив в меню RADIUS новый сервер:

Настройка параметров RADIUS

 

Service: ставим галочку на hotspot

Address: 18.197.163.142

Secret: wfp123

Timeout: 10000

 

12. Настройки мониторинга состояния площадки

Создадим скрипт для мониторинга состояний в админ-панеле сервиса. Для этого перейдем в меню System - Scheduler, и создадим новое правило в планировщике:

Mikrotik настройка скрипта мониторинга

 

Name: mon_status

Interval: 00:01:00

On Event:

:local mac [system routerboard get serial-number];

:if ( [system routerboard get routerboard] = yes ) do {

         :set mac [system routerboard get serial-number]

} else {

        :set mac [interface ethernet get ether1 mac-address]

};

/tool fetch keep-result=no mode=http address=c.wi-fi-point.com host=c.wi-fi-point.com src-path=("status\?type=routeros&station_id=$mac&identity=".[/system identity get name]."&curtime=".[/system clock get time]."&uptime=".[/system resource get uptime]."&cpu_load=".[/system resource get cpu-load]."&board_name=".[/system resource get board-name]."&free_memory=".[/system resource get free-memory])

 

13. Настройка площадки

Настройка площадки подошла к концу, теперь произведем настройки в Личном кабинете сервиса WiFi Point. Для дальнейшей работы нам необходимо зарегистрироваться по ссылке и авторизоваться в панеле.

Перед созданием площадки необходимо создать шаблон дизайна. В данной статье мы будем использовать уже существующие шаблоны из WiFi Point Маркет. Переходим в данное меню:

WiFi Point Market выбор дизайна площадки

 

В данном меню выберем шаблон наиболее подходящий тематике нашей площадки (к примеру кафе)

Шаблоны дизайнов для площадок

 

После нажатия кнопки “Получить” в меню Шаблоны дизайнов появится шаблон из маркета, который можно отредактировать потом под свои задачи указав текст, логотип, цветовую гамму и фон страницы.

Дизайн страницы приветствия

 

Перейдем в меню Wi-Fi Площадки - Все площадки. Каждый роутер соответствует новой площадке. Создадим новую площадку.

Создание площадки в сервисе WiFi Point

 

Заполните поле Название. В поле Дизайн Площадки выбираем доступный шаблон.

В данной статья мы будем рассматривать быстрый цикл авторизации без смс и ваучеров, собственно его и укажем в поле Цикл авторизации. Более детально с логикой работы каждого из циклов можно ознакомится в документации.

Открываем вкладку Настройки устройства. Укажем тип оборудования Mikrotik (RouterOS). В поле Station ID вводим серийный номер нашего роутера (меню в Winbox System - RouterBoard).

Настройка параметров площадки сервиса WiFi авторизации по СМС

 

Настройка в панеле подошла к концу, нажимаем кнопку Создать. Теперь самое время приступить к тестам.

 

14. Тест

Подключаемся к сети WiFi. Если все верно настроили, то вы должны увидеть страницу-приветствия. После нажатия Продолжить посетитель получит доступ в Интернет.

Captive Portal wifi для кафе, ресторана

 

Если вы хотите использовать площадку в маркетинговых целях и проводить рекламные кампании, то для этого переходим в меню Дополнительно-Реклама. В данном меню собственно создается сам баннер и рекламная кампания.

Выполнив несложные действия по настройке маршрутизатора, вы получили инструмент который готов приносить пользу и прибыль вашему бизнесу. При подключении посетитель будет видеть страницу-приветствия с логотипом и названием вашего бизнеса, что будет повышать узнаваемость вашего бренда. Сервис имеет гибкий функционал, который можно использовать в различных целях будь то просто брендированная страница авторизации либо рекламная информация или опрос посетителей. Пройдя регистрацию на сайте WiFi Point вы получите 1 месяц тестового периода, чтоб оценить весь функционал и преимущества инструмента взамен обычной работы роутера.

Данный сервис позволит вам:

  • настраивать страницу-приветствия при подключении к вашей публичной сети wifi
  • управлять площадками удаленно из админ панели
  • проводить смс идентификацию посетителя
  • предоставлять доступ на основе кода ваучеров
  • ограничивать трафик/время/скорость чтобы равномерно распределить канал между всеми гостями
  • проводить рекламные компании в ваших заведениях
  • проводить опросы
  • ограничивать доступ к публичной сети согласно графика работы заведения
  • иметь информацию по устройствам, возврат/удержание гостя, кол-во посещений, статистику авторизаций.

p.s. Если у Вас не получилось настроить все с первого раза и где то была допущена ошибка - воспользуйтесь автоматической настройкой хотспот авторизации на Mikrotik. Устройство будет настроено за 10 секунд, а вам останется только ввести его серийный номер в панеле сервиса (предварительно создав дизайн шаблона и площадку).

 

Печатная версия Поделитесь статьёй:
  • Обычная форма
  • Facebook

Отзывы о статье


Добавить отзыв
Ваше Имя: *
Ваш e-mail:  

Отзыв: *
Оценка:  
Введите символы: *
Обновить
 
Call-центр
  • +38 097 085-80-08
  • +38 099 238-88-98
  • +38 099 322-60-10
  • +38 063 563-33-93
  • График работы:
    Пн–Пт с 9 до 18
Магазины
  • Киев: +38 044 223-10-98
  • Харьков: +38 057 764-02-54
  • Днепр-ск: +38 056 767-50-05
  • Запорожье: +38 061 707-78-07
Наши партнеры
     
© 2003–2019 «Компания ТехноТрейд»
интернет-магазин сетевого оборудования
×
×
Валюта: