Продукция
 
Производители
 
Новости
 
Статьи

Использование MikroTik с сервисом No-IP

28.05.2012

Содержание:

  1. Регистрация и создание домена на сервисе No-IP
  2. Настройка скрипта MikroTik для использования сервиса No-IP
  3. Проверка работы скрипта с сервисом No-IP

Некоторые провайдеры (например Укртелеком) предоставляют своим пользователям динамический IP адрес, который постоянно изменяется при переподключении. Если вам необходимо подключиться к роутеру MikroTik удаленно из интернета, вы не сможете этого сделать, поскольку не будете знать, какой новый динамический адрес присвоил провайдер.

В этой ситуации нам придет на помощь сервис no-ip.com. Сервис позволяет бесплатно создать доменное имя третьего уровня (например: mikrotik.no-ip.org) и быстро обновлять информацию о том, какой IP адрес соответствует вашему доменному имени. Благодаря сервису No-IP вы сможете подключаться к роутеру MikroTik из интернета не по IP адресу, а по доменному имени.

Для удаленного подключения к роутеру MikroTik с динамическим IP адресом необходимо выполнить следующее:

  • Зарегистрироваться на сайте no-ip.com и создать свое доменное имя;
  • Настроить в роутере MikroTik скрипт, который будет обновлять информацию о текущем IP адресе роутера.

Регистрация и создание домена на сервисе No-IP

Заходим на сайт no-ip.com и нажимаем ссылку Create Account.

Регистрируемся на сервисе No-Ip

В поле Free DNS нажимаем кнопку Sign Up.

Free DNS - No-IP

Вводим информацию для регистрации:

  • First Name: - ваше имя;
  • Last Name: - ваша фамилия;
  • Email: - адрес электронной почты;
  • Username: - имя пользователя;
  • Password: - пароль;
  • Confirm Password: - подтверждаем пароль;
  • Security Question: - выбираем секретный вопрос, ответив на который, вы сможете восстановить пароль, если его забудете.
  • Your Answer: - секретный ответ на секретный вопрос;
  • Birthday: - день рождения.

Потом ставим галочку напротив «I agree that I will only create one free No-IP account» и для создания аккаунта нажимаем кнопку Accept, Create My Account.

No-IP: Вводим информацию для регистрации

Далее появится сообщение о том, что вам необходимо зайти на свой электронный почтовый ящик и подтвердить регистрацию.

No-IP: Подтвердите регистрацию

Заходим на свой email и подтверждаем регистрацию нажатием на ссылку.

Подтверждаем регистрацию на сервисе No-IP

После этого вас перебросит на страницу, которая сообщает об успешной регистрации.

No-IP: Регистрация успешно завершена

Теперь нажимаем на ссылку Login, вводим свой email, пароль и нажимаем кнопку Login.

No-IP: Вводим email и пароль

Выбираем Add a Host (добавить доменное имя).

No-IP: Добавляем доменное имя

В поле Hostname указываем имя и выбираем, в каком домене оно будет. Мы выбрали имя technotrade в домене no-ip.org. Для создания доменного имени нажимаем кнопку Create Host.

No-IP: Указываем доменное имя

Следующее окно говорит о том, что мы успешно создали доменное имя technotrade.no-ip.org

No-IP: Доменное имя успешно создано

Настройка скрипта MikroTik для использования сервиса No-IP

Добавим в роутер MikroTik скрипт, который будет обновлять IP адрес для нашего доменного имени на сервисе No-IP.

Подключаемся к MikroTik с помощью утилиты WinBox.

Подключаемся к роутеру MikroTik с помощью WinBox

Открываем меню System - Scripts и нажимаем кнопку Add (красный крестик), чтобы создать новый скрипт.

MikroTik: Создаем скрипт

В поле Name: указываем имя скрипта, например noip.
Оставляем права для скрипта : write, test, read.

MikroTik: Настраиваем параметры скрипта

В поле Source: вставляем следующий скрипт:

# Параметры подключения к NO-IP.com
:local ddnsuser "логин на NO-IP.com"
:local ddnspass "пароль на NO-IP.com"
:local ddnshostname "ИМЯ.no-ip.org
:local ddnsinterface "ИМЯ ИНТЕРФЕЙСА на Mikrotik"

# Описание глобальных переменных
:global ddnslastip
:local str
:local ddnsip
:local ip

:if ([ :typeof $ddnslastip ] = nil ) do={ :global ddnslastip "0" }

:local ddnsip [ /ip address get [/ip address find interface=$ddnsinterface ] address ]

:if ([ :typeof $ddnsip ] = nil ) do={
   :log info ("ServiceDNS: No ip address on $ddnsinterface .")
} else={

# Из полученного на интерфейсе IP адреса исключаем маску
   :for i from=( [:len $ddnsip] - 1) to=0 do={ 
      :if ( [:pick $ddnsip $i] = "/") do={ 
       :set ddnsip [:pick $ddnsip 0 $i];
      } 
   }

  :if ($ddnsip != $ddnslastip) do={

    :log info ("ServiceDNS: $ddnshostname -> $ddnsip")

# Отправляем новый IP адрес на сервис No-IP с помощью HTTP запроса
    :local str "/nic/update?hostname=$ddnshostname&myip=$ddnsip"
    /tool fetch url="http://dynupdate.no-ip.com/$str" mode=http user=$ddnsuser password=$ddnspass \ dst-path=("/ServiceDNS.".$ddnshostname)
    :delay 1 

# Сохраняем результаты в лог файлах
    :local str [/file find name="ServiceDNS.$ddnshostname"];
    :log info [/file get $str contents];
    /file remove $str
    :global ddnslastip $ddnsip

  } 

}

 

Теперь изменим в скрипте параметры подключения к сервису NO-IP. Для этого редактируем следующие переменные:

  • :local ddnsuser "логин на NO-IP.com" - указываем в кавычках логин;
  • :local ddnspass "пароль на NO-IP.com" - указываем в кавычках пароль;
  • :local ddnshostname "ИМЯ.no-ip.org" - в кавычках указываем ваше доменное имя;
  • :local ddnsinterface "ИМЯ ИНТЕРФЕЙСА MikroTik" - в кавычках указываем имя WAN интерфейса. В нашем случае это ether1. Если вы используете PPPoE соединение, то необходимо указать имя PPPoE интерфейса.

Для сохранения скрипта нажимаем кнопку OK.

Теперь в окне Script List появился наш скрипт.

MikroTik: Список скриптов

 

Далее необходимо настроить планировщик (Sheduler), который будет выполнять скрипт с определенной периодичностью.

Открываем меню System - Sheduler и нажимаем кнопку Add (красный крестик), чтобы добавить новую задачу.

MikroTik: Добавить задание в планировщик

В открывшемся окне настраиваем параметры задачи:

  • в поле Name указываем имя задачи, например noip;
  • в поле Interval указываем с какой периодичностью будет выполняться скрипт. Мы указали интервал 5 минут. Для первичной отладки лучше указать интервал 30 секунд;
  • в поле On Event указываем, какую команду необходимо выполнить при запуске задачи. Мы указали команду /system script run noip, которая запускает скрипт noip;
  • выбираем права для задачи: write, test, read;
  • нажимаем кнопку OK для сохранения задачи.

MikroTik: Настройка параметров задачи планировщика

После этого скрипт начнет свою работу.

Проверка работы скрипта с сервисом No-IP

Открываем меню NewTerminal и вводим команду system script environment print.
В консоли в столбце VALUE отобразится ваш IP адрес.

MikroTik: Отобразить IP адрес для No-IP

 

Теперь проверим, изменяется ли IP адрес на сервисе No-IP.

Логинимся на сайте no-ip.com и выбираем Manage Hosts.

No-IP: Управление доменными именами

Как видим, на сайте IP тоже изменился.

No-IP: Проверка обновления IP адреса

Теперь вы можете подключаться к роутеру MikroTik с помощью утилиты WinBox по доменному имени (в нашем случае по имени technotrade.no-ip.org).

Напоследок перезагрузите роутер MikroTik, чтобы провайдер присвоил ему новый IP адрес, и повторите проверку работы скрипта.

Печатная версия Поделитесь статьёй:
  • Обычная форма
  • Facebook

Отзывы о статье

  Оценка: 5, Голосов: 26, Комментариев: 58
Sivich 16.11.2015 11:50:12
Добрый день.
При выполнении скрипта на сайт no-ip.com отправляется ip адрес микротика в локалке, а не внешний...
[admin@MikroTik] > system script environment print
# NAME VALUE
0 ddnslastip 192.168.8.2

Схема включения:

Internet --> 3g router --> wan port mikrotik

Сеть 192.168.8.0/24 между 3g роутером м микротиком.
на WAN порту 3g роутера внешний ip.
w_fog 15.11.2015 23:56:11
всё получилось.
если в имени скрипта точка, то не работает
Вова 28.09.2015 16:17:29
сделайте статью с новой функцией cloud
настройка vpn pptp и др...
Gerich 18.09.2015 08:29:12
всё пашет! спасибо автору, и с первого разу заработал))))
Саша 30.03.2015 02:54:57
Сделал все как написано, no ip работает, из локальной сети захожу в роутер по доменному имени, а с работы через интернет не заходит. Наверное нужно еще что то прописать в фаерволе?
Николай 24.12.2014 22:28:17
Спасибо автору статьи, за проделанную работу.
Владимир 27.09.2014 15:19:34
Подскажите, как доработать скрипт, если:
- интерфейс ether1 смотрит не в интернет, а в еще один роутер, у которого уже реальный ip.
- Иными словами, может ли сервис noip работать определяя с какого адреса идут запросы и на основании этого адреса менять записи DNS?
Denis 01.09.2014 11:52:27
Статья хорошая, но надо помоч с правилами фаервола. у меня по умолчанию не работает приходится вырубать правила
Sasha 09.10.2014 12:31:14
Что ты вырубаешь? У меня скрип не работает, не подхватывает DDNS. Во премя запроса system script environment print выдает кусок кода, а не IP
Техподдержка 09.10.2014 15:17:45
Начиная с прошивки RouterOS v6.14 у MikroTik появилась своя служба Dynamic DNS. Настройки находятся в меню IP - Cloud.
Теперь можно подключаться к устройству по имени вида 123456789abc.sn.mynetname.net, где 123456789abc - это серийный номер устройства. Единственный недостаток, что это имя нельзя изменить.
Sasha 09.10.2014 22:14:42
Спасибо работает. Мб и сам найду, до вашего ответа. Но как теперь получить доступ к роутеру через WinBox ?
Sasha 09.10.2014 23:29:20
Нашел:) Настроил FireWall. Мб есть достойные статейки для настройки этой функции (FireWall) за ранние спасибо.
KGravsky 30.08.2014 15:32:10
Скрипт сказка ! огромнейшее спасибо !

Сам на микротике имею 2 ppoe соединения, как только на одном пропадает пинг -> поднимается второе.

И чтобы на сайте no-ip все менялось -> просто создал 2 скрипта, с разными именами ppoe.
Страницы: 1, 2, 3, 4

Добавить отзыв
Ваше Имя: *
Ваш e-mail:  

Отзыв: *
Оценка:  
Введите символы: *
Обновить
 
Call-центр
  • +38 097 085-80-08
  • +38 099 238-88-98
  • +38 099 322-60-10
  • +38 063 563-33-93
  • График работы:
    Пн–Пт с 9 до 18
Магазины
  • Киев: +38 044 223-10-98
  • Харьков: +38 057 764-02-54
  • Днепр-ск: +38 056 767-50-05
  • Запорожье: +38 061 707-78-07
Наши партнеры
     
© 2003–2020 «Компания ТехноТрейд»
интернет-магазин сетевого оборудования
×
×
Валюта: