Продукция
 
Производители
 
Новости
 
Статьи

Использование MikroTik с сервисом No-IP

28.05.2012

Содержание:

  1. Регистрация и создание домена на сервисе No-IP
  2. Настройка скрипта MikroTik для использования сервиса No-IP
  3. Проверка работы скрипта с сервисом No-IP

Некоторые провайдеры (например Укртелеком) предоставляют своим пользователям динамический IP адрес, который постоянно изменяется при переподключении. Если вам необходимо подключиться к роутеру MikroTik удаленно из интернета, вы не сможете этого сделать, поскольку не будете знать, какой новый динамический адрес присвоил провайдер.

В этой ситуации нам придет на помощь сервис no-ip.com. Сервис позволяет бесплатно создать доменное имя третьего уровня (например: mikrotik.no-ip.org) и быстро обновлять информацию о том, какой IP адрес соответствует вашему доменному имени. Благодаря сервису No-IP вы сможете подключаться к роутеру MikroTik из интернета не по IP адресу, а по доменному имени.

Для удаленного подключения к роутеру MikroTik с динамическим IP адресом необходимо выполнить следующее:

  • Зарегистрироваться на сайте no-ip.com и создать свое доменное имя;
  • Настроить в роутере MikroTik скрипт, который будет обновлять информацию о текущем IP адресе роутера.

Регистрация и создание домена на сервисе No-IP

Заходим на сайт no-ip.com и нажимаем ссылку Create Account.

Регистрируемся на сервисе No-Ip

В поле Free DNS нажимаем кнопку Sign Up.

Free DNS - No-IP

Вводим информацию для регистрации:

  • First Name: - ваше имя;
  • Last Name: - ваша фамилия;
  • Email: - адрес электронной почты;
  • Username: - имя пользователя;
  • Password: - пароль;
  • Confirm Password: - подтверждаем пароль;
  • Security Question: - выбираем секретный вопрос, ответив на который, вы сможете восстановить пароль, если его забудете.
  • Your Answer: - секретный ответ на секретный вопрос;
  • Birthday: - день рождения.

Потом ставим галочку напротив «I agree that I will only create one free No-IP account» и для создания аккаунта нажимаем кнопку Accept, Create My Account.

No-IP: Вводим информацию для регистрации

Далее появится сообщение о том, что вам необходимо зайти на свой электронный почтовый ящик и подтвердить регистрацию.

No-IP: Подтвердите регистрацию

Заходим на свой email и подтверждаем регистрацию нажатием на ссылку.

Подтверждаем регистрацию на сервисе No-IP

После этого вас перебросит на страницу, которая сообщает об успешной регистрации.

No-IP: Регистрация успешно завершена

Теперь нажимаем на ссылку Login, вводим свой email, пароль и нажимаем кнопку Login.

No-IP: Вводим email и пароль

Выбираем Add a Host (добавить доменное имя).

No-IP: Добавляем доменное имя

В поле Hostname указываем имя и выбираем, в каком домене оно будет. Мы выбрали имя technotrade в домене no-ip.org. Для создания доменного имени нажимаем кнопку Create Host.

No-IP: Указываем доменное имя

Следующее окно говорит о том, что мы успешно создали доменное имя technotrade.no-ip.org

No-IP: Доменное имя успешно создано

Настройка скрипта MikroTik для использования сервиса No-IP

Добавим в роутер MikroTik скрипт, который будет обновлять IP адрес для нашего доменного имени на сервисе No-IP.

Подключаемся к MikroTik с помощью утилиты WinBox.

Подключаемся к роутеру MikroTik с помощью WinBox

Открываем меню System - Scripts и нажимаем кнопку Add (красный крестик), чтобы создать новый скрипт.

MikroTik: Создаем скрипт

В поле Name: указываем имя скрипта, например noip.
Оставляем права для скрипта : write, test, read.

MikroTik: Настраиваем параметры скрипта

В поле Source: вставляем следующий скрипт:

# Параметры подключения к NO-IP.com
:local ddnsuser "логин на NO-IP.com"
:local ddnspass "пароль на NO-IP.com"
:local ddnshostname "ИМЯ.no-ip.org
:local ddnsinterface "ИМЯ ИНТЕРФЕЙСА на Mikrotik"

# Описание глобальных переменных
:global ddnslastip
:local str
:local ddnsip
:local ip

:if ([ :typeof $ddnslastip ] = nil ) do={ :global ddnslastip "0" }

:local ddnsip [ /ip address get [/ip address find interface=$ddnsinterface ] address ]

:if ([ :typeof $ddnsip ] = nil ) do={
   :log info ("ServiceDNS: No ip address on $ddnsinterface .")
} else={

# Из полученного на интерфейсе IP адреса исключаем маску
   :for i from=( [:len $ddnsip] - 1) to=0 do={ 
      :if ( [:pick $ddnsip $i] = "/") do={ 
       :set ddnsip [:pick $ddnsip 0 $i];
      } 
   }

  :if ($ddnsip != $ddnslastip) do={

    :log info ("ServiceDNS: $ddnshostname -> $ddnsip")

# Отправляем новый IP адрес на сервис No-IP с помощью HTTP запроса
    :local str "/nic/update?hostname=$ddnshostname&myip=$ddnsip"
    /tool fetch url="http://dynupdate.no-ip.com/$str" mode=http user=$ddnsuser password=$ddnspass \ dst-path=("/ServiceDNS.".$ddnshostname)
    :delay 1 

# Сохраняем результаты в лог файлах
    :local str [/file find name="ServiceDNS.$ddnshostname"];
    :log info [/file get $str contents];
    /file remove $str
    :global ddnslastip $ddnsip

  } 

}

 

Теперь изменим в скрипте параметры подключения к сервису NO-IP. Для этого редактируем следующие переменные:

  • :local ddnsuser "логин на NO-IP.com" - указываем в кавычках логин;
  • :local ddnspass "пароль на NO-IP.com" - указываем в кавычках пароль;
  • :local ddnshostname "ИМЯ.no-ip.org" - в кавычках указываем ваше доменное имя;
  • :local ddnsinterface "ИМЯ ИНТЕРФЕЙСА MikroTik" - в кавычках указываем имя WAN интерфейса. В нашем случае это ether1. Если вы используете PPPoE соединение, то необходимо указать имя PPPoE интерфейса.

Для сохранения скрипта нажимаем кнопку OK.

Теперь в окне Script List появился наш скрипт.

MikroTik: Список скриптов

 

Далее необходимо настроить планировщик (Sheduler), который будет выполнять скрипт с определенной периодичностью.

Открываем меню System - Sheduler и нажимаем кнопку Add (красный крестик), чтобы добавить новую задачу.

MikroTik: Добавить задание в планировщик

В открывшемся окне настраиваем параметры задачи:

  • в поле Name указываем имя задачи, например noip;
  • в поле Interval указываем с какой периодичностью будет выполняться скрипт. Мы указали интервал 5 минут. Для первичной отладки лучше указать интервал 30 секунд;
  • в поле On Event указываем, какую команду необходимо выполнить при запуске задачи. Мы указали команду /system script run noip, которая запускает скрипт noip;
  • выбираем права для задачи: write, test, read;
  • нажимаем кнопку OK для сохранения задачи.

MikroTik: Настройка параметров задачи планировщика

После этого скрипт начнет свою работу.

Проверка работы скрипта с сервисом No-IP

Открываем меню NewTerminal и вводим команду system script environment print.
В консоли в столбце VALUE отобразится ваш IP адрес.

MikroTik: Отобразить IP адрес для No-IP

 

Теперь проверим, изменяется ли IP адрес на сервисе No-IP.

Логинимся на сайте no-ip.com и выбираем Manage Hosts.

No-IP: Управление доменными именами

Как видим, на сайте IP тоже изменился.

No-IP: Проверка обновления IP адреса

Теперь вы можете подключаться к роутеру MikroTik с помощью утилиты WinBox по доменному имени (в нашем случае по имени technotrade.no-ip.org).

Напоследок перезагрузите роутер MikroTik, чтобы провайдер присвоил ему новый IP адрес, и повторите проверку работы скрипта.

Печатная версия Поделитесь статьёй:
  • Обычная форма
  • Facebook

Отзывы о статье

  Оценка: 5, Голосов: 26, Комментариев: 58
Виталий 26.04.2013 18:29:33
У меня что то сделал все как у вас у меня почему то айпишник меняется и уже не переходит на домен. в чем может быть дело помогите решить проблемку.
Виталий 26.04.2013 22:03:08
У меня проблемка как у Bogdan которого сообщения ниже у меня тоже этот рб 750 и у меня тоже нет у валуэ нечего.
SerMas 17.04.2013 05:04:30
Спасибо. Все работает.
alex 08.04.2013 14:02:52
ну например, заменить :local ddnsinterface "ИМЯ ИНТЕРФЕЙСА на Mikrotik"
на
:local ddnsinterface
:if ([ /ping 8.8.8.8 interface=основной_интерфейс count=3 ] = 3) do={set ddnsinterface основной_интерфейс} else={set ddnsinterface дополнительный_интерфейс}
Сергей 02.03.2013 06:08:15
Спасибо огромное за статью.......очень помогла
Bogdan 27.02.2013 23:45:33
Здаствуйте.
Вот меня именно эта тема очень заинтересовала вот просидел уже несколько часов возле этого скрипка, брал с разных сайтов, но так и не получилось увидеть работоспособность.
У меня RB750 данный скрипт так и не удалось корректно сложить в кучу что бы он заработал, может для данной модели что то отдельно дописывать нужно?
Дима 28.02.2013 09:49:57
проверил, скрипт рабочий. запусти отдельно скрипт без планировщика и посмотри что в логах пишет. может у тебя в планировщике Start Date и Start Time не соответствуют системному времени.
Bogdan 28.02.2013 16:21:55
Дмитрий, время обновляется автоматом с нета. Скрипт запускал и вручную, и через планировщик скрипт запускается в логах есть, логин пароль перепроверил несколько раз, ошибки исключены. Вот когда в терминале прописывается команду, ЮЗЕР ИМЯ и ВАЛУЕ то там где валуе-пусто! в логах пишет:\"Сервис ДНС: ...НОИП.орг и показивает ИП который отправляет по сути\" а вот в терминале то пусто, где в чем может быть проблема?
fedya 07.02.2013 20:11:29
заработало!!!
Евгений 25.12.2012 15:45:32
Отлично работает, спасибо.
Продолжение темы будет, с использованием нескольких подключений?
Если работает основное подключение то адресс ему присваевается, а если упало, то имя присваевается резервному подключению.
sanpen 06.01.2014 08:51:41
Да тоже интересует продолжение, может кто уже сделал на 2 провайдера скриптик !
xdavid 04.12.2012 22:26:06
Класс! Правда ребут модема был попутан на ребут роутера, а так впечатляет, к тому же когда не по крупному работать то сервис то бесплатный
Страницы: 1, 2, 3, 4

Добавить отзыв
Ваше Имя: *
Ваш e-mail:  

Отзыв: *
Оценка:  
Введите символы: *
Обновить
 
Call-центр
  • +38 097 085-80-08
  • +38 099 238-88-98
  • +38 099 322-60-10
  • +38 063 563-33-93
  • График работы:
    Пн–Пт с 9 до 18
Магазины
  • Киев: +38 044 223-10-98
  • Харьков: +38 057 764-02-54
  • Днепр-ск: +38 056 767-50-05
  • Запорожье: +38 061 707-78-07
Наши партнеры
     
© 2003–2020 «Компания ТехноТрейд»
интернет-магазин сетевого оборудования
×
×
Валюта: